Z archiwum x

Tydzień z Ubuntu 9.10


Życie potrafi zaskakiwać każdego, nawet takiego jak ja. Otóż zarzekałem wielokrotnie, że z aktualizacją ubuntu poczekam do kwietnia, kiedy wydadzą 10tkę. Pech chciał inaczej i zostałem zmuszony do zainstalowania 9.10

Jak doszło do tego?

Z niewiadomych przyczyn, system zaczął świrować kilka dni wcześniej a zaczęło sie od problemów przy zapisie / odczycie plików (tutaj akurat robiłem prezentację) – to była noc z czwartku na piątek. Potem, o dziwo dobrze chodziło, aż do niedzieli popołudnia – wówczas znów się system zacinał, tyle przy kopiowaniu z dysku na pendrive. W poniedziałek postanowiłem działać, fsck itp. wykrył faktyczne problemy z ext3 i podjął się naprawy. Po tym już ubunciak nie wstał, więc z pomocą płyty LiveCD ponownie wklepałem fsck, tyle że ma mi naprawić wszystkie błędy – zakończyło się z sukcesem, pojawił się bootloader i dane pofragmentowane w katalogu /lost+found.
Nowa relokalizacja zgubionych katalogów i plików na tyle mnie zirytowała, że postanowiłem podstawić wszystko od nowa. Z tego miejsca chcę podziękować lukersowi za udostępnienie łącza, bo na iplusie to bym chyba do końca życia instalował te wszystkie potrzebne pierdoły.

Houston, znów mam (miałem) problem!

Przynajmniej miałem okazję do stworzenia nowego porządku i podstawienia wszystkiego oficjalnie na ext4, który w moim przekonaniu działa, tak jakby, szybciej. Zgodnie z sugestiami wielu osób, dysk podzieliłem na 2 partycje (/ i /home) i szalałem dalej czyli apache, php, mysql, java etc. wszystko to, co mi do tej pory było potrzebne w codziennym użytkowaniu.
Oczywiście nie obyło się bez problemów i to było w zasadzie norma. Otóż instalowanie sterowników nvidii (190.xxx) zakończyło się failem i wysypał się xorg już na etapie logowania. Nie ukrywam, że ogarnęła mnie mała panika, ale i też wielki wkurw, bo znów wszystko instalować na nowo?

NoWay! 

Wówczas z pomocą przyszedł tryb naprawy, znajdujący sie w grub’ie i z konsoli należało usunąć najpierw wszystko to, co było związane z nvidią

sudo apt-get remove –purge nvidia*

a następnie próbowałem

dpkg-reconfigure xorg-server

Nie dało nic, więc szukam/pytam dalej. Gdzieś przeczytałem, że warto odinstalować i ponownie zainstalować xorg

sudo apt-get remove –purge xorg
sudo apt-get install xorg*

po czym wpisałem

startx

ubunciak w końcu ruszył i na szczęście wszystko było w porządku. Szybki update w celu dociągnięcia ewentualnych braków i znów dalsza konfiguracja systemu. Tym razem postanowiłem działać bez sprawdzonych sterowników nvidii – efektowne rzeczy z compizem w roli głównej nie są mi na razie potrzebne, choc brakuje mi przede wszystkim przezroczystości :(.

Szybka konkluzja: bez pomocy drugiego komputera, szybkiego łącza, naprawa uszkodzonego xorg’a byłaby bardzo utrudniona. Są rzeczy, które sprawiają że linuksowe desktopy są nie do końca user-friendly.

Co tym razem spartaczyli ?

Wiele zmian zaszło w tym 9.10, wiele nowych rzeczy sie pojawiło, lecz niestety spierdolili chociażby działanie NetworkManager. Nie wiem co oni zrobili, ale o wiele gorzej chodzi niż na 9.04, widzę to po często zrywanych połączeniach, odmowie połączenia/logowania się do sieci czy trudnościach w ustawieniu alternatywnych dns (obecnie korzystam z opendns dla iplusa, bo uważam, że stabilniej działa net).
Warto odnotować, na korzyść ubuntu, ułatwienie w dodawaniu nowych repozytorium, co minimalizuje konieczność edytowania za każdym razem listy za pomocą gedit’a. Ale … jakoś przyzwyczaiłem się tradycyjnej formy czyli tej konsolowej.

No i wreszcie – dźwięki działają bez konieczności przywracania ich za pomocą konsoli (o tym pisałem wcześniej). Ciekawe, jak długo tak będzie trwało – oby tak do następnej aktualizacji ubuntu.

End

Co by tu napisać więcej? Że spodziewałem się czegoś nowego innowacyjnego? Że będziemy świadkami och ach systemu? Ważniejsze jest jednak to, ze działa w miarę dobrze i w końcu można przestać się bawić/użerać się z konfiguracją. 

Techniczne
Samsung r580: regulacja jasności i optymalne zarządzanie procesorami
Techniczne
Samsung-Tools
Techniczne
nginx + php5-fpm: instalacja i konfiguracja serwera
najnowszy najstarszy oceniany
Powiadom o
Paolo
Gość

Śledziłem Twoje wpisy na Blipie i rzeczywiście widać było tą jakże problematyczną przygodę. Niemniej pomimo problemów, jakie miałem nawet ja (na samym początku) można uznać, że 9.10 jak najbardziej pozytywnie. ;]

bobiko
Gość

@Paolo
Po tym wszystkim, to były kilka blipnięć, że niby namacalnie doświadczyłem powody, dla których większość narzeka. No ale po tym wszystkim, jakoś udało mi uporządkować sprawy i zabrać się za robote :)

Zal
Gość

NetworkManager. Ależ to ssie. I tak co miesiąc psują i naprawiają go. Wrr.

Co nie zmienia faktu, że na najnowszej zabawce postawię zapewne serwerową edycję Ubuntu pomimo tego, że to nie jest 1337 ;p

bobiko
Gość

@Zal
Może i ssie, pomimo tych opisanych problemów, to NM działa dobrze, bardzo dobrze. jakże się ucieszyłem przy 8.10, gdyby mogłem odpalić nowy modem Huawei :)

Kazislav
Gość

Fakt. Problemów na początku trochę było. Zwłaszcza małe niedogodności ale po poprawie jest naprawdę dobrze. Do tego zainstalowałem sobie KDE i jestem jak na razie bardzo z tego zadowolony. Jak na razie Plasma wysypała mi się tylko raz (jak zainstalowałem jakiś dziwny Plasmoid w wersji 0.0.0.0.0.0.0.1 :))

Airborn
Gość

WM zawsze można zamienić wicd, w domowych warunkach sprawdza się świetnie, niestety na PG nie mogę się podłączyć do żadnej sieci przez niego :/

bobiko
Gość

@airborn: też myslałem o wicd, ale usłyszałem od dobrzego mi znanego speca od iplusa, ze to nie działa z modemami gsm. Ale wifi powinny chodzic

Graveer
Gość

@bobiko, Airborn: Również polecam WIcd, od sieci gsm jest wvdial, a co do sieci na PG, macie tam jakiegoś VPNa?

Karol „Zal” Zalewski
Gość

@Graveer: WPA Enterprise oparte na TTLS oraz druga sieć – EduRoam (TLS).

lolek
Gość
lolek

Niedziałające modemy Huawei dla wszystkich użytkowników internetu „mobilnego” musiały być bardzo nie miłą niespodzianką a nawet w „known issues” się nie znalazło na stronie Ubuntu. Jeśli ktoś nie miał dualboota i zrobił aktualizację …

toster
Gość
toster

Hmm to nie do konca tak z tymi modemami…
istotnie nie dzialaja modemy Huawei, natomiast spokojnie mozna uzywac polaczenia przez telefony GSM :-)
przynajmniej w moim wypadku Network Manager te polaczenia obsluguje bezproblemowo…
swoja droga ciekawe…

Przemo
Gość
Przemo

Tak z czystej ciekawosci… xorg sie posypało i CO było w logach? Zazwyczaj w logach jest informacja co nie gra i instalowanie/reinstalowanie/uruchamianie magicznych komend nie jest potrzebne.
Instalowanie wszystkiego od nowa to brzydki nawyk zaszczepiony ludzim przez M$…
pozdrawiam

bobiko
Gość

@przemo osobiście to nie pamiętam co było, ale przy instalacji sterowników od nvidii padł xorg i tyle. Jeśli się nie mylę, to był dość znany problem bo odp znalazłem na wiki ubuntu. Przeinstalowałem xorg.a i po problemie..

%d bloggers like this: